Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: My Blog Posts are not Getting Indexed! :(

  1. #11
    Try editing your robots.txt to control what search engine spiders can access. This should easily eliminate the problem of duplicate content.

  2. #12
    This is my .htacess file

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Options +FollowSymLinks
    RewriteCond %{HTTP_HOST} ^domain\.com$ [NC]
    RewriteRule ^(.*)$ http://www.domain.com/$1 [R=301,L]
    </IfModule>

    # END WordPress
    and robots.txt

    Sitemap: http://www.purepakistani.com/sitemap.xml

    User-agent: *
    Disallow: /wp-content/
    Disallow: /wp-admin/
    Disallow: /wp-includes/
    Disallow: /wp-
    Disallow: /feed/
    Disallow: /trackback/
    Disallow: /cgi-bin/

    User-agent: Googlebot
    Disallow: /*.php$
    Disallow: /*.js$
    Disallow: /*.cgi$
    Disallow: /*.xhtml$
    Disallow: /*.php*
    Disallow: */feed*
    Disallow: */trackback*
    Disallow: /*?*
    Disallow: /z/
    Disallow: /wp-*
    Disallow: /*.inc$
    Disallow: /*.css$
    Disallow: /*.txt$
    Allow: /wp-content/uploads/

    User-agent: Googlebot-Image
    Allow: /*
    Please someone confirm, that both are ok or not.

    Thank you

  3. #13
    Join Date
    May 2009
    Location
    New York
    Posts
    3,772

  4. #14
    I never used those ping's, Dunno why peoples using it anyway.

    Don't put all your eggs in one bucket, Search in the forum for extra SEO details.

  5. #15
    Quote Originally Posted by bogart View Post
    Using WordPress › All in One SEO Pack WordPress Plugins Plugin may have you avoid dupicate content. Also make sure that you have a sitemap.

    I am using All In One SEO Plugin and do have a sitemap.


    Quote Originally Posted by metros View Post
    I never used those ping's, Dunno why peoples using it anyway.

    Don't put all your eggs in one bucket, Search in the forum for extra SEO details.
    Dude, I read more then 40 articles in one day! You want me to read more? I am not getting, why bots are giving weight age to frontpage more then the original post. I mean most the front page doesn't have the whole post but excerpts and most of the blogs do so.

    Anyone has a solution? I should use a static page on frontpage? Help guys!

    PS: Somebody can tell me whether my robots.txt and .htacess files are good or not please.

  6. #16
    Quote Originally Posted by F-GD View Post
    This is my .htacess file



    and robots.txt



    Please someone confirm, that both are ok or not.

    Thank you
    I don't use any of those and got pages indexed within minutes.

    I just the robots.txt with sitemap link inside, And that's it.

  7. #17
    When I remove .htacess file, my single posts do not open (page not found).

  8. #18
    Join Date
    May 2009
    Location
    New York
    Posts
    3,772
    I seeing the following message fir your description when I search on your url in Google: "Parse error: syntax error, unexpected '<' in /home/earnerpo/public_html/purepakistani/wp-content/themes/epsilon/header.php on line 54."

    [ame=http://www.google.com/search?hl=en&rlz=1R2GGLL_enUS328&q=http%3A%2F%2Fww w.purepakistani.com&btnG=Search&aq=f&oq=&aqi]http://www.purepakistani.com - Google Search[/ame]=

    Additionally using the site command your sites has 387 indexed pages. The case may be that you don't have enough PR going into the site. So some pages are not indexed or in the supplemental index.

  9. #19
    Quote Originally Posted by bogart View Post
    I seeing the following message fir your description when I search on your url in Google: "Parse error: syntax error, unexpected '<' in /home/earnerpo/public_html/purepakistani/wp-content/themes/epsilon/header.php on line 54."

    http://www.purepakistani.com - Google Search=

    Additionally using the site command your sites has 387 indexed pages. The case may be that you don't have enough PR going into the site. So some pages are not indexed or in the supplemental index.
    I was changing something and it resulted into that error and the same time Google crawled index page. That's why it was showing that error. Now it's ok.

    Would this solve the issue?

    I change the index page from summary posts to just title links to post?

    Thank you

  10. #20
    Join Date
    May 2009
    Location
    New York
    Posts
    3,772
    Quote Originally Posted by F-GD View Post
    Would this solve the issue?

    I change the index page from summary posts to just title links to post?

    Thank you
    That's a good idea. You will need to test it. Pls keep us updated.

    I still believe that you need more PR and inbound links. Are you submitting the posts to dofollow social bookmark sites and are you getting deeplinks to posts?

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. [WTS] Blog posts on PR 2 Travel blog
    By zika in forum Links
    Replies: 0
    Last Post: 17 December, 2009, 22:42 PM
  2. [WTS] Blog Posts and Spots on PR4 Tech Blog
    By F-GD in forum Links
    Replies: 1
    Last Post: 16 November, 2009, 14:14 PM
  3. Replies: 0
    Last Post: 3 September, 2009, 16:44 PM
  4. [WTS] Blog Posts at PR3 Gaming Blog
    By deluxdon in forum Links
    Replies: 0
    Last Post: 4 June, 2009, 10:47 AM
  5. Replies: 5
    Last Post: 9 February, 2009, 17:44 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •