Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 60

Thread: 404 Error with the Translation Script

  1. #21
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Right, but FTP or Plesk?

  2. #22
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    Either, both -- whatever you have.

    I'm going to be grumpy with anything that isn't SSH, but I'll see what I can do.
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  3. #23
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    2 PMs sent, thanks again.

  4. #24
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    Dave:

    It looks like the difference between your host and mine is that Apache on my host responds to requests on localhost.

    This was a new undocumented requirement of 2.16.

    Eric added a flag to tr_config to remove this requirement.

    I'd like you to try this new revision of the script, 2.16a.

    Here's an excerpt from the changelog:
    Improvements in Release 2.16a

    New option added: do_check_url option, default false

    This checks to ensure that the requested URI/L exists before sending it to the translator.

    When true, it can reduce load on the translation servers by preventing the attempted translation of URLs which do not exist.

    This must be set to false if your server cannot talk to itself.

    The check_url_proxy variable is the host which the script will use to check URLs. The default is 'localhost:80'.
    Attached Files Attached Files
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  5. #25
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    On first glance, works perfect!

    Thanks you so much, this has made my week, thanks for sticking with me.

  6. #26
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Eeeek.

    If I translate my root; Then try and navigate to any other page the links are broken.

    "&prev=hp" seems to be being added to the end of every URL.

    I'm off to investigate.
    Last edited by davesnake; 2 May, 2009 at 18:56 PM.

  7. #27
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    Wow, that was one quick install!

    I just saw a page on your forum, in German.

    Thanks for sticking with me on this troubleshooting journey!
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  8. #28
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Does the funny links on the root too, with all my htaccess removed, think it may be the script again, sorry.
    Last edited by davesnake; 2 May, 2009 at 18:56 PM.

  9. #29
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    The first thing I would try would be to edit translate/translate.php and change the trans_url from this:
    Code:
    http://translate.google.com/translate?hl=en&sl=en&tl=$lang&u=$url&prev=hp
    To this:
    Code:
    http://translate.google.com/translate?hl=en&sl=en&tl=$lang&u=$url
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  10. #30
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    That fixes the link, but, say you are looking at my root in german, you click the link and it goes back to english.

    Is that normal or should it navigate to the next page in german also.

    Thanks for the help.

Page 3 of 6 FirstFirst 12345 ... LastLast

Similar Threads

  1. Translation Script Documentation
    By Will.Spencer in forum Translation Script Support
    Replies: 28
    Last Post: 12 October, 2012, 21:02 PM
  2. Translation Script Error 503
    By ytutun in forum Translation Script Support
    Replies: 4
    Last Post: 3 October, 2010, 22:07 PM
  3. Translation script not working
    By jagman in forum Translation Script Support
    Replies: 1
    Last Post: 5 September, 2009, 06:40 AM
  4. Need Help Configure Translation Script
    By sagarshah in forum Translation Script Support
    Replies: 7
    Last Post: 24 April, 2009, 09:34 AM
  5. Need help with this Translation Script!
    By coder77 in forum Translation Script Support
    Replies: 1
    Last Post: 26 February, 2009, 20:05 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •