Page 1 of 6 123 ... LastLast
Results 1 to 10 of 60

Thread: 404 Error with the Translation Script

  1. #1
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    404 Error with the Translation Script

    Sorry to be a PITA Will.

    It throws a 404 error when I click any of the flags.

    Also it was not working with Yahoo either, was this fixed? I get a 404 error with the new version also.

    And what does better subfolder support mean exacly.

    Thanks.
    Last edited by davesnake; 24 April, 2009 at 14:42 PM.

  2. #2
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    Quote Originally Posted by davesnake View Post
    Sorry to be a PITA Will.
    This script isn't the easiest to use.

    Quote Originally Posted by davesnake View Post
    It throws a 404 error when I click any of the flags.
    Can you post or PM me a URL?

    Quote Originally Posted by davesnake View Post
    Also it was not working with Yahoo either, was this fixed?
    I have not looked at the Yahoo translations in a long time, because of translation quality issues.

    Quote Originally Posted by davesnake View Post
    And what does better subfolder support mean exacly.
    That was a bug fix where content in subdirectories would not be translated properly. That's an older bug and I don't recall the details at this time.
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  3. #3
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Probably best if i post in my own thread rather than hijack :/

    I realised I have a htaccess in the subfolder my forum is in, if I remove that i get the following error.

    The requested URL /translate/g/pt was not found on this server.

    So why the script isnt generating the folder and then the cached page I dont know.

  4. #4
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    The script, in most cases, doesn't have access to create the /translate/g/ folder.

    Once you create /translate/g/, what error message do you get?
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  5. #5
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I created the /g as per the instructions and 777'd it when i installed.

  6. #6
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    /g or /translate/g?

    Even not looking at /forum, there is an issue.

    This URL is from one of my sites:
    Code:
    http://www.be-a-private-investigator.net/lang/pt/index.shtml
    Swapping your domain name for mine and changing index.shtml to index.html should make a workable URL for your site -- but instead it generates a 404.
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  7. #7
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    /translate/g/

    Yeah, even on my root i get 403.

  8. #8
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You don't have permission to access /translate/g/ on this server.

    or

    <url removed> - error:403

    My root is unmessed with, all i have is a index.html so it should be pretty straigthforward.
    Last edited by davesnake; 2 May, 2009 at 18:54 PM.

  9. #9
    Will.Spencer's Avatar
    Will.Spencer is offline Retired
    Join Date
    Dec 2008
    Posts
    5,033
    Blog Entries
    1
    Thanks
    1,010
    Thanked 2,327 Times in 1,258 Posts
    One oddball question...

    Do you have /lang and /translate in / or in /forums/?
    Submit Your Webmaster Related Sites to the NB Directory
    I swear, by my life and my love of it, that I will never live for the sake of another man, nor ask another man to live for mine.

  10. #10
    davesnake is offline Newbie Net Builder
    Join Date
    Mar 2009
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    both are on the root.

Page 1 of 6 123 ... LastLast

Similar Threads

  1. Translation Script Documentation
    By Will.Spencer in forum Translation Script Support
    Replies: 28
    Last Post: 12 October, 2012, 21:02 PM
  2. Translation Script Error 503
    By ytutun in forum Translation Script Support
    Replies: 4
    Last Post: 3 October, 2010, 22:07 PM
  3. Translation script not working
    By jagman in forum Translation Script Support
    Replies: 1
    Last Post: 5 September, 2009, 06:40 AM
  4. Need Help Configure Translation Script
    By sagarshah in forum Translation Script Support
    Replies: 7
    Last Post: 24 April, 2009, 09:34 AM
  5. Need help with this Translation Script!
    By coder77 in forum Translation Script Support
    Replies: 1
    Last Post: 26 February, 2009, 20:05 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •