I'm having an issue figuring out a 404 error I'm getting a lot.

An example:

The error.log:
[Thu Aug 19 11:21:48 2010] [error] [client 204.236.103.28] File does not exist: /var/www/www.parkinggames.net/htdocs/play/4, referer: http://www.parkinggames.net/play/4/Park-Master-2.html

Access.log:
204.236.103.28 - - [19/Aug/2010:11:21:47 -0500] "GET /play/4/Park-Master-2.html HTTP/1.1" 200 5083 "http://www.parkinggames.net/play/18/Truck-Stop-Parking.html" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.5; InfoPath.2; .NET CLR 2.0.50727; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; AskTB5.6)"
204.236.103.28 - - [19/Aug/2010:11:21:48 -0500] "GET /images/sad.gif HTTP/1.1" 200 880 "http://www.parkinggames.net/play/4/Park-Master-2.html" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.5; InfoPath.2; .NET CLR 2.0.50727; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; AskTB5.6)"
204.236.103.28 - - [19/Aug/2010:11:21:48 -0500] "GET /play/4/ HTTP/1.1" 404 180 "http://www.parkinggames.net/play/4/Park-Master-2.html" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.5; InfoPath.2; .NET CLR 2.0.50727; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; AskTB5.6)"

Awstats:
http://www.nux.net/img/8b1dcc1f391047fb6809598b2a81bd6e.png

So you can see it happens a lot.

I've seen it happen in IE7 and IE8 so it doesn't seem to be specific to just IE6 or a single browser.

If someone could take a look at it that would be awesome. I've tried a couple times to figure it out, and a lot more looking now and just unable to find it.

Thanks,
-nux