Results 1 to 9 of 9

Thread: Interesting Error Trying to view Netbuilders with Glype.

Hybrid View

  1. #1

    Interesting Error Trying to view Netbuilders with Glype.

    I"m trying to read netbuilders threw a proxy. lol
    But! Whenver I click on a url that has new-post.html on it. It does 2 301 redirects.
    And ends up redirecting a 404 error.


    Trying putting the url below in the code tags into either of these Glype proxy sites: http://freesslproxy.com (mine) or http://guardtunnel.com (Someone else's)
    (Guardtunnel doesn't return the same error message though. Mine is custom)


    Code:
    http://www.netbuilders.org/search-engine-news/bings-crawler-still-slow-8495-new-post.html
    ERROR: 404

    Attempted to Find: http://www.netbuilders.org/services/custom-flash-tutorials-5-per-tutorial-1-free-tutorial-every-2-tutorials-622.htm
    This resource you requested returned the error: 404.
    A 404 not found error occurs when the requested resource does not exist on a website.
    Go back or Go to Homepage
    Weird! That the not the post That was requested.
    I noticed the same problem on Digitalpoint Forum has started recently too. My thoughts are the that VBSeo's 301 redirects get messed up somewhere in Glype.


    Edit:

    I found the problem! Upon furthing examining. After you request the url with "new-post.html" VbSeo send a 302 moved redirect of
    Code:
    Location: http://www.netbuilders.org/showthread.php?p=70906#post70906
    But Glype Truncates the "6" of the end and asked for
    Code:
    http://www.netbuilders.org/showthread.php?p=7090
    Which redirects to the thread about the custom flash tutorials, but even that a 404 becuase it then truncates the "l" of .html which we end up with.
    Code:
    http://www.netbuilders.org/services/custom-flash-tutorials-5-per-tutorial-1-free-tutorial-every-2-tutorials-622.htm

    Glype looks to have bug that needs some correcting.
    What the hell is doing trunating the "6" off the url? Wierd..
    Submit new proxies -

  2. #2
    I found someone else spotted this error.
    url is truncated when redirecting in phpbb (maybe somewhere in regex pattern) / glype proxy script - free anonymous proxies list

    The Glype author never fixed it, probably ignored that guys thread. So maby just remove the -1 off the function as described in the above link.
    Submit new proxies -

  3. #3
    Join Date
    Feb 2009
    Location
    New York, USA
    Posts
    1,137
    Thanks for this post, I'm fixing it on GuardTunnel.com right now.

    Edit: Applied fix and works. I'm curious why that was there in the first place though. In the comments it says "Extract any #anchor since we don't want to encode that"
    WiredStorm Hosting Solutions
    █ Lightning Fast Shared and Reseller Hosting
    █ cPanel with Softaculous and 24/7 Email (Ticket) Support
    Biodegradable Sunscreen - Unblock Facebook

  4. #4
    Yeah no problem Zash. I wonder why the -1 was beside the $tmp. What was the Glype author trying to achieve?

    Edit:

    "Extract any #anchor since we don't want to encode that"
    Since # are used for <a name=""> anchors. They would need tobe removed and added to the end of the URL like so:

    browse.php?u=jdlfkjsdklfjsdlkjflds#something

    LikeWise this is why Orkut doesn't work threw Glype their using # in their urls to update the content dynamically. But the # was not meant for content to be loaded for ajax, its meant for auto scrolling to certain parts in the html via <a name=""> tags. So its not really the fault of Glype software. Its moreso thier's for breaking the valid use of the anchor tag!
    Submit new proxies -

  5. #5
    Join Date
    Feb 2009
    Location
    New York, USA
    Posts
    1,137
    So does that mean Orkut should start working now?
    WiredStorm Hosting Solutions
    █ Lightning Fast Shared and Reseller Hosting
    █ cPanel with Softaculous and 24/7 Email (Ticket) Support
    Biodegradable Sunscreen - Unblock Facebook

  6. #6
    I dont know, if you have an Orkut account try it out and post your results. I dont have one and dont feel like signing up there.
    Submit new proxies -

  7. #7
    Join Date
    Feb 2009
    Location
    New York, USA
    Posts
    1,137
    Yea I don't have one either. Oh well, I don't really get any Orkut users.
    WiredStorm Hosting Solutions
    █ Lightning Fast Shared and Reseller Hosting
    █ cPanel with Softaculous and 24/7 Email (Ticket) Support
    Biodegradable Sunscreen - Unblock Facebook

  8. #8
    That Glype thread with the Fix is Thead Number 1337.

    forums.glype.com/index.php?topic=1337.msg6925 <-- 1337 message. lol
    Submit new proxies -

  9. #9
    Sweet, thanks man. Yesterday, I actually noticed an e-mail from a user asking me to fix Orkut. This should do it.

Similar Threads

  1. Replies: 2
    Last Post: 2 February, 2010, 03:38 AM
  2. Glype libcurl error
    By rome9t9 in forum Web Proxies
    Replies: 25
    Last Post: 16 November, 2009, 05:15 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •