every time i update my wordpress this error occur which iswhy i'm still using WordPress 2.8.6.

i entered the correct hostname, user and password but it seems not going thru..

Downloading update from http://wordpress.org/wordpress-2.9.2.zip.
Unpacking the update.
Verifying the unpacked files
The update could not be unpacked
Installation Failed
anyone experienced this too?